Responsive Tabs / Posts /

mc not working when loaded via Ajax

20
Hi i just noticed that tabs loaded inside an ajax call dont work, to be more especific a tab that is inside a tab thats calling it via ajax 
Carlos  10 years ago   viewed: 8133    

13 Answers

0
i did what you said and still not working, also i did some digging and found out that the posible cause of this is that the plugging is disabled when the tab is fired via ajax Is there a chance to reactivate it or a way to fix this?
Carlos
  10 years ago
2
Your mctabs.css contains improper settings. The selectors should be ul.mctabs instead of ul.tabs, and you should copy the settings from our demo mctabs.css, not the free version tabcontent.css.
Milo   10 years ago
0
Can you explain me why is working here http://www.noradio.mx/leftside/inicio.php but not here http://www.noradio.mx?
Carlos
  10 years ago
-1
I cannot see it is working at http://www.noradio.mx/leftside/inicio.php

I recommend you to use our McTabs demo code from scratch.

Milo   10 years ago
0
look for the videos section on this page http://www.noradio.mx/leftside/inicio.php
and look for the same section on this one http://www.noradio.mx please i know this might be anoying by now but i really need to take care of this an  dont mean to be that  way i just need to finish this project
Carlos
  10 years ago
0
Because your http://www.noradio.mx is using http://www.noradio.mx/css/tab1.css that is for the Tabbed Content (free version). You cannot use it for McTabs.
Milo   10 years ago
0
I just changed that and still the same problem
Carlos
  10 years ago
0
Then would you use our demo as the start from scratch(HTML, CSS, and JS), and get rid of any script copy of the free version tab content?
Milo   10 years ago
0
The problem is the tab Inicio in the part that says +videos you ll se a video and to the right the links are supposed to be tabs but they don't work
Carlos
  10 years ago
1
I found you have at least two misuse:
1. It should be <div class="panel-container">, not <div class="panel">
2. Where is the mctabs.css?
Milo   10 years ago
0
Maybe the ajax call is not fired.
I do not understand well about your scenario. It may help us understand better if you have a testing page.
Milo   10 years ago
0
www.noradio.mx is the webpage i'm designing is in spanish and the problem is when i try to trigger a part that says videos in side the ajax 
Carlos
  10 years ago
0
I viewed your page with Chrome and didn't see anything wrong with the McTabs Ajax call.

I do see a couple of other errors in your page when I press the F12 button and open the Console panel in the Chrome. You can try the same (press the F12 button) and see the errors.
Milo   10 years ago

   

Your name*
Password
(Optional. Used to modify this post afterwords)
+ =  

Ask your Own Question

  • If your question is related to the topic of this post, you can post your question to this page by clicking the "Post a reply" button at left;

  • When you want to start a new page for your question: